1. Что такое Разведчик (What is The Explorer?) icon

1. Что такое Разведчик (What is The Explorer?)




Скачати 229.66 Kb.
Назва1. Что такое Разведчик (What is The Explorer?)
Дата конвертації23.12.2013
Розмір229.66 Kb.
ТипДокументи
1. /!!!ВНИМАНИЯ !!!.docx
2. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Metastcok & ID Loader - дубль два_files/count.txt
3. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Metastcok & ID Loader - дубль два_files/count_002.txt
4. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Metastock 8.0 Professional_files/count.txt
5. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Metastock 8.0 Professional_files/count_002.txt
6. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Metastock 8.0 и ID Loader 4.4.4 отказываются работать вместе_files/count.txt
7. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Metastock 8.0 и ID Loader 4.4.4 отказываются работать вместе_files/count_002.txt
8. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Metastock 8.0, в первый раз..._files/count.txt
9. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Metastock 8.0, в первый раз..._files/count_002.txt
10. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/PowerPivots80.pdf
11. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/UpdatedIndex_PRO_551.pdf
12. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/UpdatedIndex_PRO_553.pdf
13. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Вопрос по Metastock_files/count.txt
14. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Вопрос по Metastock_files/count_002.txt
15. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Вопрос по Метастоку (очередной )_files/count.txt
16. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Вопрос по Метастоку (очередной )_files/count_002.txt
17. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/И снова Метасток_files/count.txt
18. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/И снова Метасток_files/count_002.txt
19. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Как в метасе сделать последнюю свечу нормально_files/count.txt
20. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Как в метасе сделать последнюю свечу нормально_files/count_002.txt
21. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Метасток и Метатрейдер_files/count.txt
22. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Метасток и Метатрейдер_files/count_002.txt
23. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Можно ли поднять $200_files/count.txt
24. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Можно ли поднять $200_files/count_002.txt
25. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Не могу подружить IDLoader и Metastock_files/count.txt
26. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Не могу подружить IDLoader и Metastock_files/count_002.txt
27. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Проблема с Метасток 8.0_files/count.txt
28. /Metastock 7.0 8.0. 9.0/Metastcok - ФОРУМ/Проблема с Метасток 8.0_files/count_002.txt
29. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/DownLoader/ВВЕДЕНИЕ.DOC
30. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/DownLoader/Команды меню.doc
31. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/DownLoader/Начало работы.doc
32. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/DownLoader/Приложение 1.doc
33. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/DownLoader/Приложение 2.doc
34. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/DownLoader/Сообщения об ошибках конвертации.doc
35. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/DownLoader/Таблица данных.DOC
36. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Creating Your Own Indicators.doc
37. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/The Explorer.doc
38. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Интерпретация индикаторов.doc
39. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Концепция графика.doc
40. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Начало работы.doc
41. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/ПЕЧАТЬ.DOC
42. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Работа с аналитическими линиями.doc
43. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Работа с графиками (что такое график).doc
44. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Работа с графиками цен.doc
45. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Работа с индикаторами.doc
46. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Рабочая область.doc
47. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/СЛОВАРЬ.DOC
48. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Свойства графика.DOC
49. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Тестирование торговых систем.doc
50. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Форматы.doc
51. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Шаблоны.doc
52. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/MetaStock/Японские свечи.doc
53. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/Optscop/АНАЛИЗ.DOC
54. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/Optscop/ВВЕДЕНИЕ.DOC
55. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/Optscop/Начало работы.doc
56. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/Optscop/Опции меню.doc
57. /Metastock 7.0 8.0. 9.0/Инструкция к MetaStock 7.0/Метасток 7.0/Optscop/Рабочая таблица.doc
58. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/DownLoader/ВВЕДЕНИЕ.DOC
59. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/DownLoader/Команды меню.doc
60. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/DownLoader/Начало работы.doc
61. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/DownLoader/Приложение 1.doc
62. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/DownLoader/Приложение 2.doc
63. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/DownLoader/Сообщения об ошибках конвертации.doc
64. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/DownLoader/Таблица данных.DOC
65. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Creating Your Own Indicators.doc
66. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/The Explorer.doc
67. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Интерпретация индикаторов.doc
68. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Концепция графика.doc
69. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Начало работы.doc
70. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/ПЕЧАТЬ.DOC
71. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Работа с аналитическими линиями.doc
72. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Работа с графиками (что такое график).doc
73. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Работа с графиками цен.doc
74. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Работа с индикаторами.doc
75. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Рабочая область.doc
76. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/СЛОВАРЬ.DOC
77. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Свойства графика.DOC
78. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Тестирование торговых систем.doc
79. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Форматы.doc
80. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Шаблоны.doc
81. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/MetaStock/Японские свечи.doc
82. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/Optscop/АНАЛИЗ.DOC
83. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/Optscop/ВВЕДЕНИЕ.DOC
84. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/Optscop/Начало работы.doc
85. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/Optscop/Опции меню.doc
86. /Metastock 7.0 8.0. 9.0/Русская документация по Metastock/Optscop/Рабочая таблица.doc
87. /Metastock 7.0 8.0. 9.0/Справочник Основы работы с Metastock 8.0/Основы работы с программой MetaStock 8.0.doc
88. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/1 Общие сведения о программе.doc
89. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/10 Осцилляторы.doc
90. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/11 Осцилляторы на основе скользящих средних.doc
91. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/12 Объем как необходимый фактор.doc
92. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/13 Числа Фибоначчи.doc
93. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/2 Классический анализ при помощи линий.doc
94. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/3 Классический анализ при помощи фигур.doc
95. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/4 Библиотека индикаторов MetaStock 7.0.doc
96. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/5 Использование комбинаций скользящих средних.doc
97. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/6 Создание индикаторов пользователя.doc
98. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/7 Система построения стратегий.doc
99. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/8 Оптимизация торговых стратегий.doc
100. /Metastock 7.0 8.0. 9.0/Учебник по MetaStock 7.0/9 Осциллятры.doc
Оптимизация торговых стратегий
Система построения стратегий
Создание индикаторов пользователя
Использование комбинаций скользящих средних
Библиотека индикаторов MetaStock 0
Осцилляторы Индекс относительной силы (Relative Strength Index)
Общие сведения о программе
1. Что такое ОпционСкоп (What is OptionScope?)
1. Этапы оценки Опциона
1. Что такое формат (What is a Layout?)
1. Что такое тест системы? (What is a System Test?)
1. Что такое Индикатор (What is an Indicator?)
1. Что такое График ? (What is a Chart?)
1. Концепция базовой ЦБ (Base Security Concept)
1. Аккумуляционный индекс размаха (Accumulation Swing Index )
Учебник по формулам (см. Formula Tutorial) поможет вам быстро во всем раз­обраться
1. Введение (Introduction)
1. Сообщения об ошибках конвертации (Convert Error Messages)
1. Меню “File”
Программа совместимая с Microsoft Windows разработанная для управления файлами данных МетаСтока. "DownLoader" выполняет четыре основные функции
1. Что такое ОпционСкоп (What is OptionScope?)
1. Японские подсвечники (Japanese Candlestick)
1. Что такое тест системы? (What is a System Test?)
1. Стандартные функции Microsoft Windows (Microsoft Windows Standard Features)
Словарь
1. Окно Графика (Chart Window) 1Выбор Графика (Selecting a Chart)
1. Выбор и конфигурирование принтера (Selecting and Configuring Your Printer)
1. Что такое аналитическая линия (What is a Line Study?)
1. Приветствуем Вас (Welcome)
Учебник по формулам (см. Formula Tutorial) поможет вам быстро во всем раз­обраться
1. Введение (Introduction)
Коды тикеров опционов (Option Ticker Symbol Codes)
Программа совместимая с Microsoft Windows разработанная для управления файлами данных МетаСтока. "DownLoader" выполняет четыре основные функции
Осцилляторы
Классические методы анализа графика Ценовые модели
Классические методы анализа графика
Числа Фибоначчи История и свойства последовательности
Использование скользящих средних для создания осцилляторов
Объем, как необходимый фактор
Всплывающий календарь для ввода дат
1. Что надо для ОпционСкопа
1. Меню “File”
1. Японские подсвечники (Japanese Candlestick)
1. Что такое шаблон (What is a Template?)
Словарь
1. Окно Графика (Chart Window) 1Выбор Графика (Selecting a Chart)
1. Стандартные функции Microsoft Windows (Microsoft Windows Standard Features)
1. Что такое аналитическая линия (What is a Line Study?)
1. Приветствуем Вас (Welcome)
1. Выбор и конфигурирование принтера (Selecting and Configuring Your Printer)
1. Три способа управления данными (Three Ways to Manage Securities)
1. Что такое Разведчик (What is The Explorer?)
Коды тикеров опционов (Option Ticker Symbol Codes)
1. Биржевые коды (Ticker Symbols)
1. Быстрое путешествие (Quick Tour)
Всплывающий календарь для ввода дат
1. Что надо для ОпционСкопа
1. Меню “File”
1. Этапы оценки Опциона
1. Что такое шаблон (What is a Template?)
1. Что такое формат (What is a Layout?)
1. Что такое Индикатор (What is an Indicator?)
1. Концепция базовой ЦБ (Base Security Concept)
1. Что такое График ? (What is a Chart?)
1. Аккумуляционный индекс размаха (Accumulation Swing Index )
1. Три способа управления данными (Three Ways to Manage Securities)
1. Что такое Разведчик (What is The Explorer?)
1. Сообщения об ошибках конвертации (Convert Error Messages)
1. Биржевые коды (Ticker Symbols)
1. Быстрое путешествие (Quick Tour)
1. Меню “File”
Как начать зарабатывать на форексе не вкладывая свои деньги?

Эксплорер

Эксплорер

(Ranking and Screening Securities)

1.Что такое Разведчик (What is The Explorer?)


Разведчик это мощный многоцелевой аналитический инструмент при помощи которого можно выполнять углубленные исследования нескольких ЦБ из нескольких подкаталогов. Разведчик может выполнять много уникальных задач, включая сравнение, фильтрацию, пролистывание значений нескольких индикаторов для нескольких ЦБ, ранжирование, поиск, показ ЦБ с текущими сигналами "buy/sell", сортировка и т.д.

Разведчик может быть использован для:

  • Обнаружения какая из ЦБ имеет в настоящее время сгенерированный сигнал покупки (или продажи).

  • Обнаружения какая из ЦБ имеет в настоящее время пересечение графика цен с их 200-дневной скользящей средней на возрастающем объеме.

  • Обнаружения какая из ЦБ имеет в настоящее время имеет наивысшее положение по индексу “Wilder's RSI”.

  • Обнаружения какая из ЦБ в настоящее время расположена выше ее 10-недельной скользящей средней с Стохастическим осциллятором 80 или выше, и уровень пользовательской бинарной волны равен 4.

  • Генерировать отчет о движении всех Ваших денежных средств.

  • Генерировать список для каждой ЦБ со значениями шести Ваших любимых индикаторов.

  • И т.д.

Это лишь малая часть того, что может делать Разведчик.

Набор правил и критериев которые определяют этот процесс называется Исследованием (exploration). В Исследовании может быть специфицировано до шести колонок и фильтр. Критерии, при помощи которых определяются колонки используют формат пользовательских индикаторов. См. “Creating Your Own Indicators”. Список ЦБ ....A list of securities can be screened for those candidates that meet your criteria by applying a filter. Критерии фильтра используют формат тестера систем. См. “Trading Rule Syntax”. Отчет с результатами Разведки может быть выведен на экран или принтер.

Разведчик разработан так, чтобы быть простым и прозрачным в использовании и в тоже время максимально мощным инструментом. Комбинирование синтаксиса “Indicator Builder” и “System Tester” при разработке Исследований имеет простую суть, т.к. используются навыки очевидно которыми Вы уже владеете. Поэтому такие разделы как “Formula Tutorial” (см.) и “System Tester Tutorial” (см.) необходимя для начала работы и быстрого затем продвижения вперед.

Прежде чем Вы приступите к созданию Ваших первых Исследований мы советуем Вам потрптить несколько минут на следующий которкий учебник. Это поможет заложить последовательные основы к дальнейшему развитию Вашего искуства.

2.Учебник по Исследованиям (The Explorer Tutorial)


Этот раздел предлагает короткую информацию по процедурам создания исследований и просмотру результирующих отчетов. Важно, чтобы Вы прочитали этот раздел до того как приступите к разработке Ваших исследований. Кроме того Вы должны хорошо ориентироваться в синтаксисе “Indicator Builder” (См. “Formula Tutorial”) и “System Tester” (См. “Trading Rule Syntax”).

2.1Быстрое начало. Основы (Quick Start (The Basics))


В самой простой форме создание исследования включает следующие шаги:

  • Выберите пункт “Explorer” из меню “Tools”.

  • В диалоге “Explorer” выберите кнопку “New”.

  • Заполните диалог “Exploration Editor” напечатав имя исследования и формулы для шести колонок, используя синтаксис “MetaStock's Indicator Builder”. Установите филтр при помощи синтаксиса “MetaStock's System Tester”. Заметим, что критерии колонок и критерии фильтра независимы друг от друга.

  • Щелкните кнопку , а затем нажмите клавишу “Explore” в диалоге “Explorer”, чтобы запустить исследование.

Во это да! Несмотря на то, что существуют и другие функции, которые повышают мощь и гибкость “Explorer”, создание Исследования включает только эти четыре шага.

На следующих страницах этого раздела детализируется каждый из четырех шагов приведенных выше. Изучите каждый шаг внимательно, т.к. каждый последующий шаг связан с предыдущим.

2.2Диалог “Explorer” (The Explorer Dialog)


Для того, чтобы вызвать диалог “Explorer” Выберите пункт “Explorer” из меню “Tools” или щелкните по одноименной кнопке на главной панели инструментов.

Диалог “Explorer” используется, чтобы создавать Исследования, управлять ими и печатать их.

2.3Создание нового исследования (Creating a New Exploration)


  • После того как диалог “Explorer” будет выведен на экран, выберите пункт “New”. В результате появиться диалог “Exploration Editor”.

Последний является сердцем “Explorer” и используется для спецификации имени (name), колонок (column) и фильтра (filter).

  • Введите имя “My First Exploration" (do not enter the quotation marks in this, or the remaining, examples).

  • Пока Вы не специфицировали иное в диалоге “Exploration Options”, Исследование выполняется для самую последнюю дату имющуюся в Ваших файлах ЦБ. Наряду с этим, Исследование выполняется используя дневные (daily) данные, пока иное не будет специфицированно в диалоге “Exploration Options”.

  • Щелкните по переключателю “ColA” (Колонка A) и напечатайте в поле ввода формул:

CLOSE

  • Напечатайте в поле “Col.Name” (Имя колонки):

  • Close

Заметим, что в этом поле Вы можете написать, что хотите. Однако в нашем случае напишите, что указано выше.

  • Щелкните по переключателю “ColB” (Колонка B) и напечатайте в поле ввода формул:

mov(CLOSE,20,SIMPLE)

  • Напечатайте в поле “Col.Name” (Имя колонки):

MOV-20

  • Щелкните по переключателю “ColC” (Колонка C) и напечатайте в поле ввода формул:

rsi( 14 )

  • Напечатайте в поле “Col.Name” (Имя колонки):

RSI-14

Заметим, что формулы используемые в колонках имеют синтаксис идентичный синтаксису для пользовательских индикаторов. Вы даже можете ссылаться на существующие пользовательские формулы при помощи функции "FML" (например, fml("MYMACD") ). Это помогает избежать перепечатывания формул, которые уже были разработаны Вами при помощи инструмента “Indicator Builder”.

Если Вы хотите вставить формулу пользовательского индикатора, используйте кнопку “Formula”. См. “Pasting Functions Into Formulas”.

  • Выберите , чтобы вернуться в диалог “Explorer”.

  • Выберите “Explore”, чтобы начать процесс исследования.

  • Появляется диалог “Select Securities” (Выбор ЦБ), из которого выбираются ЦБ для Исследования. Выберите на дереве каталогов каталог с данными, и щелкните по кнопке “Add Dir”, чтобы данный каталог был перенесен в список “Selected Directories”.

  • В нашем случае пока щелкните по кнопке . Каждая ЦБ входящая в выбранный каталоге будет включена в Исследование. Однако, Вы можете сохранять определенные ЦБ в дополнительных каталогах.

Во время калькуляции Исследования, на экран выводится окно “Exploration Status”.

  • Когда МетаСток завершит расчет Исследования, выберите опцию “Reports” из диалога “Exploration Completed”.

Появиться окно с отчетом по результатам Исследования.

Отчет по Исследованию (Exploration Report) показывает имя каждой ЦБ и результаты расчетов по каждой колонке. Данные показанные в колонках A, B и C являются значениями цен закрытия (т.е., Close), скользящей средней с периодом 20 (т.е., mov(close,20,simple) ) и индексом относительной силы (RSI) с периодом 14 (т.е., rsi(14)) на самую последнюю дату имеющихся данных. При помощи команды “Sort” Вы можете изменить порядок расположения данных в отчете. См. “Sorting the Results Report”.

2.4Установка фильтра (Adding a Filter)


При помощи фильтра Вы можете сузить список до ЦБ удовлетворяющих определенному критерию. Вы можете ссылаться в формуле фильтра на значения получаемые в формулах колонок, или же можете написать критерии фильтра абсолютно независящие от формул колонок. Фактически Вы можете разработать Исследование с пустыми колонками и имеющее только один фильтр.

В нашем случае, мы напишем фильтр, который оставляет в списке ЦБ с ценой закрытия ниже ее скользящей средней с периодом 20 и RSI с периодом 14 ниже 40. Поскольку цена закрытия и приведенные выше индикаторы уже имеются в колонках A, B и C, мы можем сэкономить время и при написании фильтра сослаться непосредственно на эти колонки.

  • Щелкните по клавише “Close”, чтобы закрыть отчет.

  • Выберите Исследование "My First Exploration", и щелкните по клавише “Edit”.

  • Щелкните по переключателю “Filter”.

  • В поле ввода формул запишите следующее:

(colA < colB ) and (colC < 40)

Заметим, что формулу фильтра также можно написать как:

(CLOSE < mov(CLOSE,20,SIMPLE))and(rsi(14)<40)

Если Ваш фильтр базируется непосредственно на формулах колонок (как показано выше), Вы можете некоторым образом уменьшить себе работу, напечатав простую ссылку на колонки при помощи переменной "COL" (т.е., colA и colB). особенно это удобно, когда формулы колонок очень длинные.

  • Синтаксис формул фильтров идентичен синтаксису “MetaStock's System Tester”. Вы можете даже ссылаться на существующие пользовательские индикаторы при помощи функции "FML" (например, fml("MYMACD") ). Это помогает избежать перепечатывания формул, которые уже были разработаны Вами при помощи инструмента “Indicator Builder”.

  • Щелкните по клавише “Options” в диалоге “Exploration Editor”. Активизируйте флажок “Use Filter” (Использовать фильтр) в диалоге “Exploration Options”, чтобы активизировать фильтр. Чтобы установленный фильтр действовал этот флажок должен быть выбран. Щелкните .

  • Нажмите клавишу , чтобы Вы выйти из диалога “Exploration Editor”.

  • Чтобы выполнить Исследование с вновь добавленным фильтром, щелкните по клавише “Explore”.

  • Когда МетаСток закончит расчеты по данному исследованию, выберите клавишу “Reports” из диалога “Exploration Completed”. Появится отчет с результатами Исследования.

Заметим, что в отчете присутствуют только ЦБ цена закрытия которых ниже ее скользящей средней с периодом 20 и RSI с периодом 14 меньше 40.

Если Вы хотите сделать список ЦБ еще более узким, Вы должны вернуться в диалог “Exploration Editor” и сделать фильтр еще более ограничивающим:

  • Нажмите клавишу “Close”, чтобы выйти из отчета.

  • Выделите “My First Exploration", и выберите клавишу “Edit”.

  • Измените формулу фильтра на следующую:

(colA < colB) and (colC < 30)

  • Щелкните по клавише , для возврата в диалог “Explorer dialog”.

  • Чтобы выполнить Исследование с более ограничивающим фильтром, нажмите клавишу “Explore”.

  • Когда МетаСток закончит расчет Исследования, выберите опцию “Reports” в диалоге “Exploration Completed”. Будет выведен отчет с результатами Исследования.

Заметьте, что количество ЦБ представленных в данном отчете вероятно меньше чем в предыдущем, потому что часть фильтра с индексом RSI является более ограничивающей.

  • Чтобы просмотреть “историю” значений колонок для определенной ЦБ, то выберите нужную ЦБ в отчете “Results” и щелкните по клавише “Inspect”.

2.5Заключние (Tutorial Summary)


  • Эксплорер дает Вам свою мощь и гибкость как многоцелевой аналитический инструмент, который помогает выполнить глубинное исследование Ваших ЦБ.

  • Исследование включает формулы колонок и фильтр. Несмотря на то, что эти штуки вводятся в одном диалоге и могут быть скомбинированы в одиночное Исследование, все же колонки и фильтр это разные вещи и имеют каждый свою функцию.

  • Формулы колонок используют мощный синтаксис “Indicator Builder”. См. “Formula Tutorial”. В этих формулах можно использовать ссылки на существующие пользовательские индикаторы при помощи функции "FML" (например, fml("My MACD") ).

  • Критерий фильтра использует мощный синтаксис “System Tester”. См. “Creating a System Test”. Здесь также можно использовать ссылки на существующие пользовательские индикаторы при помощи функции "FML" (например, fml("My MACD") ).

  • Кроме того в фильтре можно использовать ссылки непосредственно на формулы в колонках при помощи переменной "COL" (например, colA).

  • Результаты Исследования представляются в Отчетах. См. “Results Report”. Каждая ЦБ в этом отчете сортируется в соответстви со значениями какой либо колонки, колонка для сортировки задается в соответствующем диалоге.

  • История значений колонок для определенной ЦБ может быть выведена при клавиши “Inspect” отчета “Results”.

3.Диалог “Explorer” (The Explorer Dialog)


Диалог “Explorer” вызывается при помощи опции “Explorer” из меню “Tools” или одноименной кнопкой на главной панели инструментов. В диалоге “Explorer” приводится список имен всех Ваших Исследований. Вы можете создать до 1000 Исследований. выбранное Исследование можно редактировать, копировать, удалять, печатать и тестировать. Для Исследований, справа от имени которых расположен символ "R", в наличии имеются Отчеты по самым последним Исследованиям.

New. (Новый) Используется чтобы вызвать диалог “Exploration Editor”, в котором Вы можете специфицировать имя (name), имена и формулы колонок (columns) и критерий фильтра для нового Исследования. См. “Creating an Exploration”.

Edit. (Редактирование) Используется для вызова диалога “Exploration Editor”, в котором можно отредактировать уже существующее Исследование.

Copy. (Копирование) Используется для копирования выбранного Исследования. См. “Copying and Deleting Explorations”.

Delete. (Удаление) Используется для удаления выбранного Исследования. См. “Copying and Deleting Explorations”.

Print. (Печать) Используется для печати выбранного Исследования. См. “Printing Explorations”.

Explore. (Исследование) Используется для запуска выполнения процесса исследования выбранного Исследования. См. “Running the Exploration”.

Reports. (Отчеты) Используется для вывода Отчета результатов (Results Report) выбранного Исследования. Эта кнопка недоступна (серого цвета), если выбранное Исследование не имеет отчета. Признак наличия отчета - символ "R" справа от имени Исследования. См. “Viewing the Reports”.

Options. (Опции) Используется для вызова диалога “Explorer Options”, в котором Вы можете настроить опции по управлению данными и отчетами. См. “Explorer Options”.

3.1Диалог “Explorer Options” (Explorer Options)


Диалог “Explorer Options” используется, чтобы настроить опции, которые воздействуют на все Исследования. Чтобы вызвать диалог “Explorer Option”, щелкните по кнопке “Options” в диалоге “Explorer”. Как настроить опции, которые будут относиться только к определенному Исследованию см. в “Exploration Options”.

Load Minimum Records. (Загружать минимум записей) Выберите этот пункт, чтобы оптимизировать расчет Исследования и ускорить процесс расчета. При этом значения определенного типа индикаторов (т.н. кумулятивный тип) не будут точно соответствовать значениям индикатора, которые выводятся на графике (см. ниже).

Load Maximum Records. (Загружать максимум записей) выберите этот пункт, чтобы беспечить максимальную точность соответствия расчетов значений кумуллятивных индикаторов на графиках (см. ниже) их значениям при расчетах в Исследования.

Некоторые индикаторы относятся к так называемому кумулятивному типу. Получаемое значение индикатора кумулятивного типа зависит от количества загруженных данных. Например, результат полученный при расчете экспоненциальной скользящей средней с периодом 10 при загрузке данных за 40 дней будет немного отличаться от результатов, если будет загружено данных за 500 дней. Это обуславливается тем, что при расчете экспоненциальной средней более ранние данные оказывают влияние (в убывающем порядке) на получаемые результаты.

Always Prompt for Securities. (Всегда выводить список ЦБ) Активизируйте этот флажок, чтобы “Explorer” всегда выводил диалог “Select Securities” (см. “Selecting Securities to Explore”), перед началом процедуры расчета Исследования. При помощи диалога “Select Securities” Вы можете выбрать каталоги и ЦБ для Исследования.

Notify When Exploration is Done. (Извещать о завершении Исследования) Активизируйте этот флажок, если хотите чтобы диалог “Exploration Completed” появлялся на экране после завершения процедуры расчета Исследования.

4.Создание Исследования (Creating an Exploration)


Исследование выполняет две отдельные и различные задачи. Выводит список Ваших ЦБ и значений индикаторов (не более шести колонок с индикаторами). Отфильтровывает список ЦБ в соответствии с назначенным Вами критерием. Вы можете разработать не более 1000 Исследований.

Чтобы запустить Эксплорер выберите опцию “Explorer” из меню “Tools” или одноименную кнопку на главной панели инструментов.

Для создания нового Исследования выберите кнопку “New” из меню диалога “Explorer”. В результате появляется диалог “Exploration Editor”. Этот диалог используется для ввода критериев Исследования. Для Исследования Вы можете назначить формулы от одной до шести колонкам и определить критерий для одного фильтра.

Name. (Имя) В поле “Name” введите имя Исследования.

Notes. (Описание) В поле “Notes” введите описание Исследования.

Columns. (Колонки) Колонки A-F специфицируют значения, которые затем выводятся в Отчете результатов (см. “Results Report”). Для каждой колонки предначначено отдельное ввода формулы. Как только Вы щелкните по переключателю соответствующему определенной колонке появляется новое поле ввода, где можно напечатать формулу. В каждой колонке расчитывается какое либо уникальное значение. Формула колонки пишется при помощи синтакисса пользовательских индикаторов. (см. “Formula Tutorial”). Длина формулы в колонке не должна превышатьn 1,024 символов.

Functions. (Функции) При помощи данной кнопки Вы можете вызвать диалог “Paste Functions” (Вставка функций). В этом диалоге Вы можете выбрать из списка более160 функций. Выбранная функция может быть непосредственно вставлена в формулу Вашего Исследования. См. “Pasting Functions Into Formulas”.

Securities. (ЦБ) При помощи этой кнопки Вы можете вызвать диалог “Select Securities”, в котором в свою очередь можете выбрать ЦБ для Вашего Исследования. См. “Selecting Securities to Explore”.

Options. (Опции) При помощи этой кнопки вызывается диалог “Exploration Options”. В этом диалоге настраиваются опции для конкретного (выбранного) Исследования. См. “Exploration Options”.

4.1Диалог “Exploration Options” (Exploration Options)


Диалог “Exploration Options” используется, чтобы специфицировать опции, которые воздействуют только на конкретное выбранное Исследование. Чтобы вызвать этот диалог, щелкните по кнопке “Options” в диалоге “Exploration Editor”.

Этот диалог контролирует опции для определенного Исследования. Чтобы настроить опции воздействующие на все Исследования, воспользуйтесь диалогом “Explorer Options” (см.).

Most Recent Date. (Самая последняя дата) Активизируйте этот флажок, если Вы хотите использовать при расчете Исследования для каждого файла ЦБ самую последнюю дату этих файлов.

Specific Date. (Определенная дата) Активизируйте этот флажок, если Вы хотите использовать при расчете Исследования для каждого файла ЦБ какую либо определенную дату. Введите эту дату в поле “Date”. Последняя дата каждой ЦБ равна или предшествует дате, которую Вы вводите в поле Date.

Periodicity. (Периодичность) Выберите необходимую периодичность для ЦБ в Исследовании. Данные по ЦБ будут сжаты (при необходимости) соответственно вашему выбору. Например, файлы с дневными данными могут быть сжаты до недельных или месячных данных. Заметим, что попытка выбрать опцию “daily" (дневные) для файлов которые содержат недельные (weekly), месячные (monthly) или годовые (yearly) данные будет отвергнута, т.к. файлы не могут быть сжаты в более короткий периодичность.

Use Filter. (Использовать фильтр) Отметьте этот флажок, чтобы фильтр был использован. См. “Filter Syntax”.

4.2Синтаксис формул колонок (Column Formula Syntax)


Формулы колонок имеют синтаксис используемый при написании пользовательских индикаторов. (см. “Formula Tutorial”). Все функции пользовательских индикаторов могут быть использованы в колонках Эксплорера, включая функцию ссылки на существующие пользовательские индикаторы "FML". Например, если Вы захотите использовать в колонке Вашего Исследования индикатор "Combination Wave" (комплексная бинарная волна), то Вы вместо перепечатывания его формулы, можете записать fml("Combination Wave").

Следующий пример показывает формулу, при помощи которой в отчете выводятся значения разницы между скользящими средними с периодами 10 и 50:

mov(CLOSE,10,SIMPLE)- mov(CLOSE,50,SIMPLE)

Это пример формулы базовой 14-дневного RSI:

rsi(14)

Это пример формулы колонки для расчета разницы между двумя пользовательскими формулами "ROC1" и "ROC2":

fml("ROC1") - fml("ROC2")

4.3Синтаксис Фильтра (Filter Syntax)


Синтаксис применяемый для определения критериев фильтра идентичен синтаксису написания правил для Тестера систем. За исключением переменной "COL", которая применяется только для описания критериев фильтра. При помощи этой переменной Вы можете непосредственно ссылаться на формулы колонок. Это помогает избежать переписывания формул введенных в колонки и делает формулу фильтра более читабельной. Предположим, что Вы определили формулу для колонки “A” как:

mov( rsi( 20 ), 9, SIMPLE)

В настоящий момент Вы хотите, чтобы в отчете выводились только ЦБ у которых показатель колонки “А” меньше 40:

mov( rsi( 20 ), 9, SIMPLE) < 40

Однако, чтобы уберечь себя от перепечатывания данной формулы в поле фильтра и сделать ее более читабельной Вы можете использовать переменную “COL”, как показано ниже:

colA < 40

Обе формулы фильтра приводят к одним и тем же результатам, однако вторая требует меньше времени для печати. Это особенно удобно, когда Ваш фильтр состоит из длинных и сложных формул.

4.3.1Stand-alone Filters


Вместе с тем, что критерий фильтра может основываться непосредственно на выражениях занесенных в колонки, он может быть задан полностью независимым от значений колонок. В принципе колонки исследования вообще могут быть пустыми. Возможно Вы просто захотите иметь список ЦБ, который просто удовлетворяет критерию Вашего фильтра независимо от значений колонок, которые выводятся в Отчете.

Например, критерий фильтра может быть написан следующим образом:

cci(9) < -90 and mfi(6) < 50

При этом, если был специфицирован только критерий фильтра, в Отчете колонки значений индикаторов будут пустыми и только имена ЦБ будут показаны.

4.4Отбор ЦБ для Исследования (Selecting Securities to Explore)


МетаСток может включить в Исследование до 12 000 ЦБ из максимум 50 каталогов. Как каталоги, так и сами ЦБ из этих каталогов могут быть выбраны при помощи диалога “Select Securities”. Этот диалог может быть вызван при помощи кнопки “Securities” в диалоге “Exploration Editor”. Если отмечена опция “Always Prompt for Securities” (см. “Explorer Options”), то диалог “Select Securities” всегда будет появляться при запуске Исследования.

Если для Исследования по какой либо причине не были выбраны ЦБ, то диалог “Select Securities” будет вызван автоматически в качестве напоминания о необходимости выбора ЦБ.

Диалог “Select Securities” разделен на две части. В левой его части расположено дерево каталогов, которое используется для выбора каталога с файлами данных для Исследования. Список расположенный в правой части диалога показывает уже выбранные каталоги/ЦБ.

Add Dir. (Добавить каталог) При помощи этой кнопки Вы можете переметить помеченный каталог из дерева каталогов (Directories) в список отобранных каталогов (Selected Directories). Все ЦБ и подкаталоги занесенные в список “Selected Directories/Securities” будут оставаться включенными в Исследование до тех пор пока они не будут удалены из этого списка.

Remove Dir. (Удалить каталог) Используйте кнопку “Remove”, чтобы удалить отобранные каталоги из списка “Selected Directories/Securities”.

Вы можете переключаться между показом в списке “Selected Directories/Securities” каталогов и ЦБ следующими способами:

  • Двойным щелчком по имени каталога.

  • Щелчком по имени каталога и выбором переключателя “Securities”, расположенного под этим списком. Чтобы вновь показать в этом списке каталоги, щелкните по кнопке “Directories”.

По умолчанию, каждая ЦБ вновь добавленного каталога будет выбрана. Щелкните по имени ЦБ, чтобы выключить/включить ее отбор в Исследование. Галочка зеленого цвета расположенная слева от имени ЦБ указывает на то, что данная ЦБ является выбранной.

Вы можете переключать состояния выбора и отмены выбора всех ЦБ в списке, нажав клавишу SHIFT и щелкнув по имени каталога.

После того как Вы сформируете список отобранных ЦБ, щелкните по кнопке .

4.4.1Сохранение списков ЦБ (Maintaining Lists of Securities)


Диалог “Security Lists” предоставляет Вам возможность загружать и сохранять сформированные списки ЦБ для выполнения Исследования. Чтобы вызвать этот диалог, щелкните по кнопке “Lists” в диалоге “Select Securities”.

Возможно Вы захотите разделить Ваши ЦБ на определенные категории. Например Вы хотите создать несколько списков, первый из которых включает только акции компьютерных компаний, второй только товары и третий содержит акции только автомобильных компаний. Вместо того, чтобы каждый раз при запуске различных исследований выбирать каждую акцию этих категорий по отдельности, Вы можете сгруппировать их в легко вызываемый список.

Open. (Открыть) Эта кнопка используется для загрузки отмеченного списка ЦБ в диалог “Select Securities”. Имеющиеся в наличии подкаталоги будут заменены на вновь загруженные подкаталоги.

Save As. (Сохранить как) Используйте эту кнопку, чтобы назначить имя списку ЦБ из диалога “Select Securities”. Вы можете создать до 104 списков ЦБ.

Delete. (Удалить) При помощи этой кнопки Вы можете удалить выбранный список.

Print. (Печать) При помощи этой кнопки Вы можете напечатать выбранный список ЦБ.

5.Копирование и удаление Исследований (Copying and Deleting Explorations)


Вы можете сделать копию выбранного Исследования в диалоге “Explorer” при помощи кнопки “Copy”. Этот прием используется когда необходимо создать новое Исследование очень похожее на уже существующие и присвоить ему другое имя.

Например, если Исследование “A” очень похоже на новое Исследование, которое Вы хотите создать, Вы можете использовать команду “Copy” из диалога “Explorer”, чтобы сделать дубликат данного исследования, вместо того чтобы его перепечатывать. Затем Вы можете внести в данный дубликат необходимые изменения и назначить ему новое имя (Exploration B).

При помощи кнопки “Delete” из диалога “Explorer” Вы можете удалить выбранное Исследование. После щелчка по кнопке “Delete” появляется диалог “Delete Exploration”.

Выберите, что Вы хотите удалить, сами Исследования или Отчеты по Исследованиям. Если Вы удаляете Исследование, то отчеты удаляются вместе с ним.

6.Печать Исследований (Printing Explorations)


Вы можете распечатать имена и/или формулы Ваших Исследований при помощи диалога “Print”. Этот дилог вызывается при помощи кнопки “Print” из диалога “Explorer”.

Selected Exploration(s). (Выбранные Исследования) Отметьте этот переключатель, если хотите чтобы были напечатаны только выбранные Исследования.

All Explorations. (Все Исследования) Отметьте этот переключатель, если хотите чтобы были напечатаны все Исследования.

Print What. (Что печатать) Выберите пункт “Names Only”, если Вы хотите распечатать только имена Исследований. Выберите пункт “Names and Formulas”, если хотите распечатать и имена и формулы Исследования.

7.Запуск Исследования (Running the Exploration)


Для того чтобы запустить выполнение Исследования, отметьте имя нужного Исследования в списке диалога “Explorer” и щелкните по кнопке “Explore”.

Продолжительность процесса Исследования зависит от сложности формул Исследования, от количества записей загружаемых для калькуляции (см. “Explorer Options”), а также от мощности Вашего компьютера.

7.1Диалог “Exploration Status” (Exploration Status Dialog)


В течении процесса калькуляции Исследования на экране присутствует диалог “Exploration Status”. В этом диалоге выводится информация по процессу выполнения Исследования. Вы также можете сввернуть окно этого диалога. В этом случае калькуляция Исследования будет выполняться в фоновом режиме, а в это время можно загружать другие задачи.

Большинство информации выводимой в этом окне понятно само по себе. Некоторые пункты этой информации описываются ниже.

Estimated Completion Time. (Ориентировочное время окончания) Это время основано на средней продолжительности выполнения Исследования для каждой ЦБ. Этот параметр уточняется после завершения расчета Исследования для каждой ЦБ.

Execution Priority. (Приоритет выполнения) При помощи этого раскрывающегося списка Вы можете управлять ресурсами процессора направленными на выполнение калькуляции Исследования. Если Вы не собираетесь во время калькуляции Исследования загружать другие программы, то Вы можете установить режим "High". Режим "Medium" или "Low" можно установить, если программа стала вяло реагировать на Ваши команды, или же если при Исследовании запущенным в фоновом режиме, другие приложения работают слишком медленно.

Minimize. (Свернуть) Эта кнопка используется для свертывания (минимизации) диалога “Exploration Status”. Когда Исследование свернуто, Вы можете спокойно работать с другими функциями МетаСтока. Вы даже можете запустить тестирование Торговой системы, которую в свою очередь тоже можете минимизировать. См. “Testing Your Trading Ideas”.

Чтобы вновь развернуть на экране диалог “Exploration Status” выполните двойной щелчок по значку этого диалога.

Cancel. (Прервать) Вы можете прекратить процесс расчета Исследования нажав кнопку “Cancel”. После того как Вы щелкните по кнопке “Cancel” появляется окно с запросом на подтверждение данной операции. Отчеты по всем ЦБ калькуляция Исследований которых была завершена до того как Вы нажали на кнопку “Cancel” остаются и Вы их можете просмотреть. См. “Viewing the Reports”.

Как запустить Исследование в фоновом режиме:

  • Запустите Исследование”.

  • Когда появится диалог “Exploration Status”, установите необходимый приоритет выполнения в раскрывающемся списке “Execution Priority”. Если Вы планируете во время калькуляции выполнять другие задачи, требующие значительных ресурсов процессора, то выберите приоритет “Medium” или “Low”.

  • Щелкните по кнопке “Minimize”.

7.2Скорость калькуляции (Speed of Calculation)


Скорость калькуляции Исследования может быть повышена при помощи:

  • Активизации опции "Load Minimum Records" в диалоге “Explorer Options” (см.).

  • Уменьшения величин периодов используемых в формуле.

  • Уменьшения числа ссылок на пользовательские формулы (т.е. функций типа FML).

  • Исползование более мощного процессора (с математическим сопроцессором).

  • Использование “быстрого” жесткого диска.

8.Просмотр отчетов (Viewing the Reports)


Отчеты Исследования могут быть вызваны двумя путями. Во-первых вы можете выбирать кнопку “Reports” в диалоге “Exploration Completed”, который появляется непосредственно сразу после окончания калькуляции Исследования (Помните, что данный диалог появляется, если в диалоге “Explorer Options” активизирована опция "Notify When Exploration is Done". См. “Explorer Options“). Во-вторых, вы можете вызвать нужный Отчет из диалога “Explorer”. Для этого нужно выбрать необходимое Исследование из списка и нажать клавишу “Reports”. Признаком наличия Отчета у Исследования является символ "R", расположенный рядом с именем Исследования.

Для каждого Исследования создается три типа Отчетов, каждый из которых может быть вызван нажатием на соответствующую клавишу в диалоге “Reports”.

В Отчете результатов приводится каждая ЦБ (за исключением забракованных) и соответствующие ей значения колонок. Каталог откуда была взята каждая ЦБ отображается в последней колонке.

В диалоге “Rejects report” выводится имя каждой “забракованной” ЦБ и причины этого. См. “Rejects Report”.

В диалоге “Exploration Security Column Data” приводятся исторические данные значений колонок выбранных ЦБ.См. “Exploration Security Column Data Report”.

8.1Отчет результатов (Results Report)


Отчет “Results Report” (Результаты Исследования) выводит результаты Исследования. Здесь выводятся имя каждой ЦБ удовлетворяющей критерию фильтра (если таковой был установлен) со значениями всех определенных колонок. В верхней части отчета выводится имя присвоенное Исследованию

Ширина колонок в этом отчете может ругулироваться при помощи перетаскивания вертикальных разделителей , располагающихся между заголовками колонок.

Inspect. (Инспекция) Посредством этой кнопки вызывается отчет “Exploration Security Column Data” для отмеченной ЦБ. В этом отчете представляются исторические значения колонок данной ЦБ. См. “Exploration Security Column Data Report”

Sort. (Сортировка) При помощи этой кнопки вы можете осуществить сортировку отчета по любой из колонок. См. “Sorting the Results Report”.

Print. (Печать) Вызов диалога печати содержимого отчета Результатов Исследования. См. “Printing Reports”.

8.1.1Сортировка отчета Результаты Исследования (Sorting the Results Report)


Вы можете выполнить сортировку отчета Результаты Исследования по любой из колонок (включая колонку имен ЦБ) как в возрастающем так и убывающем порядке. Если для сортировки используется колонка имен ЦБ, то отчет сортируется в алфавитном порядке.

Sort by. (Колонка для сортировки) Из раскрывающегося списка выберите колонку (первичный ключ), согласно значений которой будет сортироваться отчет.

Then by. (Вторичная сортировка) Выберите из раскрывающегося списка колонку, которая будет использована в качестве ключа для сортировки внутри дублитаков, полученных при первичной сортировке. Например, если в отчете в колонке имен ЦБ, акция “IBM" встречается пять раз, то после сортировки по этой колонке строки данной акции будут идти одна за другой. Порядок расположения строк внутри этой группы и будет определятся колонкой используемой для вторичной сортировки.

Таким образом порядок сортировки установленный в опции “Sort by" действует на все строки отчета, а порядок установленный в опции “Then by", только на дублированные строки.

Ascending. (По возрастанию) Выбор этой опции устанавливает порядок сортировки по возрастанию.

Descending. (По убыванию Выбор этой опции устанавливает порядок сортировки по убыванию.

8.2Отчет “Exploration Security Column Data” (Exploration Security Column Data Report)


Отчет “Exploration Security Column Data” (Данные колонок Исследования ЦБ) относится к конкретной ЦБ. Данную ЦБ нужно отметить в отчете “Results” и щелкнуть по кнопке “Inspect”. В этом отчете выводятся данные по каждой колонке за весь период использованные для калькуляции Исследования.

Количество данных приводимых в этом отчете определяется опцией “Data Loading” установленной в диалоге “Explorer Options”. См. “Explorer Options”.

Ширина колонок отчета регулируется также как рассказано выше.

Print. (Печать) При помощи этой кнопки вы можете распечатать содержимое отчета. См. “Printing Reports”.

8.3Отчет “Rejects” (Rejects Report)


В этом отчете приводятся ЦБ, которые не были включены в отчет “Results” с коротким описанием причины.

Если в Исследовании есть фильтр, то в этом отчете будут приведены все ЦБ, которе не удовлетворяют критерию фильтра. ЦБ, которые не были включены в отчет “Results” из за ошибок также будут приведены здесь. Например, если в вашеи Исследовании расчитывается скользящая средняя с периодом 200, а вы, а вы имеете только данные за 100 дней, то такая ЦБ будет отброшена в отчет “Reject”.

Print. (Печать) При помощи этой кнопки вы можете распечатать содержимое отчета. См. “Printing Reports”.

8.4Вкладка “Exploration” (Exploration Page)


На вкладке “Exploration” выводится информация по формулам колонок, правилу фильтра, периодичности и некоторая другая информация по Исследованию.

8.5Копирование отчетов в буфер обмена (Copying Reports to the Windows Clipboard)


Вы можете скопировть содержимое Отчетов Исследования в буфер обмена, чтобы затем использовать их в других приложениях Windows.

Чтобы скопировать Отчет в буфер обмена:

  • Выведите Отчет.

  • Щелкните мышью в любом месте Отчета.

  • Нажмите комбинацию клавиш CTRL+ C (или CTRL+ Ins) с целью копирования. Затем вы можете вставить эту информацию в другое приложение Windows.

9.Примеры Исследований (Sample Explorations)


В этом разделе приводятся формулы колонок и фильтров шести Исследований. Несколько предопределенных Исследований также включены в МетаСток.

9.1Долгосрочная медвежья тенденция (Long-term Bearish)


Это Исследование отбирает ЦБ цена закрытия которых ниже ее скользящей средней с периодом 200.

Column A: close

Column B: mov(C,200,E)

Column C: ((C-mov(C,200,E)) / Abs(Mov(C,200,E)))* 100

Filter: colA < colB

В этом Исследовании список необходимых ЦБ формируется благодаря критерию фильтра. Однако, в Исследование также включены колонки с ценой закрытия, MA(200), а также отношение цены закрытия к ее MA(200) выраженное в процентах, если цена закрытия меньше MA (200).

9.2Долгосрочная бычья тенденция (Long-term Bullish)


Это Исследование показывает ЦБ у которых Close больше ее MA(200).

Column A: close

Column B: mov(C,200,E)

Column C: ((C-mov(C, 200, E)) / Abs(Mov(C, 200, E))) * 100

Filter: colA > colB

В этом Исследовании список необходимых ЦБ формируется благодаря критерию фильтра. Однако, в Исследование также включены колонки с ценой закрытия, 200-дневной скользящей средней цены закрытия, а также отношение цены закрытия к ее скользящей средней выраженное в процентах, если цена закрытия выше MA (200).

Заметьте, что отличие данного Иследования от Исследования “Long-term Bearish” заключается в символе “больше” (т.е., ">"), что стоит в формуле фильтра.

9.3Сигнал покупки MACD (MACD Buy Signal)


Это Исследование отбирает ЦБ с классическим сигналом покупки MACD (т.е., когда MACD пересекает снизу свою сигнальную линию).

Column A: close

Column B: macd()

Column C: mov(macd(),9,E)

Filter: colb > colc and ref(macd(),-1) < colc

Отбор ЦБ в Исследовании проходит согласно критерию фильтра. В Исследование также включены колонки с ценой закрытия, значениями MACD и ее сигнальной линии с периодом 9.

9.4Пять популярных индикаторов (Indicators, 5 popular)


В Исследование включены колонки со значениями цены закрытия и пяти популярных индикаторов.

Column A: close

Column B: macd()

Column C: Stoch(5,3)

Column D: cci(14)

Column E: obv()

Column F: rsi(14)

В данном Исследовании нет фильтра. Исследование может быть легко изменено, если вы захотите включить сюда свои любимые индикаторы.

9.5Performance, Daily


This exploration shows the short-term performance of each security.

Column A: close

Column B: roc(close,1, percent)

Column C: roc(close,5, percent)

Column D: roc(close,10, percent)

Column E: roc(close,30, percent)

Column F: roc(close,60, percent)

This exploration does not require a filter since we want to see every security's performance ranking. The Exploration Report has been written to include columns for five performance criteria including a one-day, five-day, 10-day, 30day, and 60-day percentage rate-of-change.

You may want to use the Sort button in the Results report to sort on one of the performance columns. For example, you could sort the report so that securities with the highest 60-day performance appear at the top.

9.6Прорыв объема и цены (Price and Volume Breakout)


Следуещее Исследование отбирает ЦБ, цены которых за последний день выросли более чем на 5% с ростом объема как минимум на 50% от среднего.

Column A: close

Column B: ref(C,-1)

Column C: roc(C,1, P)

Column D: volume

Column E: mov(V, 50, E)

Column F: ((V - mov(V, 50, E)) / mov(V, 50, E)) * 100

Filter: (colC >= 5) and (colD >= (colE * 1.5))

В отчет включаются акции удовлетворяющие критерию фильтра. Кроме того в отчете выводятся цена закрытия, цена закрытия предыдущего дня, изменение цены в процентах, объем, средний объем за последние 50 торговых дней и отношение текущего объема к его среднему значению в процентах.

10.Советы по Исследованиям (Exploration Tips)


  • Вы можете заметить, что значения колонок в Отчете Результатов Исследования не соответствуют друг другу. Это связано с особеностями расчета значений этого индикатора. Мы рекомендуем Вам избегать использования функции Per() в Исследованиях.

  • Эксплорер не будет включать в исследования Компоциции ЦБ. Если подкаталог с файлами ЦБ, которые включены в Исследование будут содержать файлы Композиций, то последние будут проигнорированны.

  • Помните, при использовании переменной типа “COL” в формулах критерия фильтра Вы непосредственно ссылаетесь на значения колонок. Применение переменных этого типа особенно удобно, когда формулы колонок очень длинные.

  • Чтобы Ваши Исследования были корректными, очень Важно, чтобы базовы данные ЦБ были точными и связанными временными отношениями. Это означает, что базовые данные каждой ЦБ по датам должны соответствовать друг другу. Если данные хотя бы одной ЦБ будет несовместимы (даже на один день), то значения выводимые в Отчете не могут считаться корректными.

  • Вы можете включить в Ваше Исследование какой либо Индекс исследования ширины рынка для его сравнения с Вашими другими ЦБ. Включение такого Индекса особенно полезно, когда Вы проводите относительное (нормализованное) ранжирование ваших ЦБ. Вместе с Метастоком поставляются различные Исследования основанные на вычислениях нормализованных величин.

  • Вы можете в формулах Исследования делать ссылки на индикаторы расположеныые на Графиках. Для этого необходимо выбрать нужный индикатор (например, щелкнув по индикаторумышью, чтобы появились “признаки” его выбора), а затем вставить в формулу колонки переменную "P" в месте, где обычно располагаются идентификаторы массива данных. Например, формула "mov(p,10,s)" будет рассчитывать для выбранного индиктора его МА(10).

  • Вы должны избегать использования функции "ref()"при ссылках на формулы колонок (например, ref(colA, -1) ). Это связано с тем, что Эксплорер расчитывает значения только на один день. И функция ref() вернет значение только на этот день.

  • Вы должны избегать использования функции "cross()" при ссылках на формулы колонок (например, cross(colB, colC) ). Это связано с тем, что для работы функции “cross()” необходимо иметь данные двух дней следующих один за другим, а Эксплорер расчитывает значения колонок на один определенный день.






Схожі:

1. Что такое Разведчик (What is The Explorer?) iconОтветы на олимпиадные здания по педагогике и психологии для 11 класса 1 вариант Что такое «интеллект»
Что такое «интеллект» с точки зрения разных научных подходов? Каковы факторы его формирования и способы развития? – 12б
1. Что такое Разведчик (What is The Explorer?) iconВопросы к экзамену по курсу «Технология Программирования Сложных Информационных Систем» ( 3 курс ) Уровень А: Особенности архитектуры. Net. Что такое «общая среда выполнения» (clr)?
Что такое управляемая куча (managed heap)? Какие типы хранятся в управляемой куче, а какие в стеке?
1. Что такое Разведчик (What is The Explorer?) iconКнига на сайте: Текст в авторской редакции
Что такое право? Как его можно определить? В чём его сущность? Что такое закон и когда он возникает? Есть ли разница между правом...
1. Что такое Разведчик (What is The Explorer?) iconЗдравствуй, грусть Франсуаза Саган
Это такое всепоглощающее, такое эгоистическое чувство, что я почти стыжусь его, а грусть всегда внушала мне уважение. Прежде я никогда...
1. Что такое Разведчик (What is The Explorer?) iconПрежде чем читать данную статью, убедитесь что вы знаете что такое скрипты sqs, переменные, циклы. Здесь не будет объяснения данных понятий, здесь мы просто рассмотрим как сделать в sqf то, что вы уже умеете делать в sqs
На практике, люди освоившие sqf в достаточной степени, уже стремятся к большему, это уже скриптеры, а не картоделы. И пояснять такие...
1. Что такое Разведчик (What is The Explorer?) iconЧто такое ислам?
Более того, мы видим, что Вселенная существует и абсолютно точно функционирует в течение многих сотен тысяч лет. Так можем ли мы...
1. Что такое Разведчик (What is The Explorer?) iconЧто такое гендерное равенство?

1. Что такое Разведчик (What is The Explorer?) iconКнига на сайте: Проблема ландшафта
Вопрос о том, что такое ландшафт интересовал учёных уже давно. По этому поводу неоднократно высказывались разные мнения, а что касается...
1. Что такое Разведчик (What is The Explorer?) iconКнига I о том, что такое государство
Соответственно общение, естественным путем возникшее для удовлетворения повседневных надобностей, есть семья; про членов такой семьи...
1. Что такое Разведчик (What is The Explorer?) iconХороший добрый смех!
Хороший добрый смех полезен не только потому, что поднимает настроение. Люди, которые любят смеяться, меньше болеют, реже раздражаются...
1. Что такое Разведчик (What is The Explorer?) iconПервоиюньский репортаж
Сто двадцать мальчишщек и девчонок песнями, хороводами и танцами рассказали о том, что такое радостное и беззаботное детство. Фонтан...
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©te.zavantag.com 2000-2017
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи