Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader icon

Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader




Скачати 254.67 Kb.
НазваМетодичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader
Дата конвертації28.11.2012
Розмір254.67 Kb.
ТипМетодичні вказівки


МІНІСТЕРСТВО ОСВІТИ І НАУКИ УКРАЇНИ


НАЦІОНАЛЬНИЙ ГІРНИЧИЙ УНІВЕРСИТЕТ


Методичні вказівки та індивідуальні завдання

до лабораторних робіт з дисципліні

“Засоби мультимедіа в нових інформаційних технологіях”

для студентів спеціальностей 7.080401 і 7.080403




Дніпропетровськ

НГУ

2005


МІНІСТЕРСТВО ОСВІТИ І НАУКИ УКРАЇНИ


НАЦІОНАЛЬНИЙ ГІРНИЧИЙ УНІВЕРСИТЕТ


Методичні вказівки та індивідуальні завдання

до лабораторних робіт з дисципліні

“Засоби мультимедіа в нових інформаційних технологіях”

^

для студентів спеціальностей 7.080401 і 7.080403




Рекомендовано до видання науково-методичним управлінням університету

(протокол № від р.)


Дніпропетровськ

НГУ

2005

Методичні вказівки та індивідуальні завдання до лабораторних робіт з дисципліні “Засоби мультимедіа в нових інформаційних технологіях” для студентів спеціальностей 7.080401 і 7.080403/Уклад.: В.О. Трусов, А.В. Кожевников.—Дніпропетровськ: НГУ, 2005. - с.


Укладачі:

В.О. Трусов, А.В. Кожевников, кандидати техн. наук, доценти.


Відповідальний за випуск завідувач кафедри програмного забезпечення комп’ютерних систем проф. Алєксєєев М.О.

^

Лабораторна робота N1

Вивчення пакета оптичного розпізнавання тексту FineReader


Мета – одержання навичок інсталяції й деінсталяції додатка Windows, вивчення інтерфейсу користувача й основних навичок роботи c OCR (Optical Character Recognition – оптичне розпізнавання символів) додатком FineReader і текстовими форматами даних.

^

Методичні вказівки до виконання


  1. Скопіювати із папки мережеве оточення – Server на диск D: робочої станції папку FineReader.

  2. Уважно вивчити інструкції з інсталяції з файлу Readme.

  3. Зробити інсталяцію пакета в папку D:\Fine.

  4. Помістити ярлик додатка Fine32 на робочий стіл, а при необхідності й у меню Пуск за допомогою послідовності команд Пуск> Настройка> Панель задач и меню «Пуск» > Меню Пуск >Настроить > Добавить > Обзор > D:\ ABBYY FineReader\FineOCR.exe > Рабочий стол або Программы > Готово > ОК.

  5. Запустити додаток, ознайомитися з його інтерфейсом користувача.

  6. Для 3–5 сторінок відсканованого тексту, зазначених викладачем зробити оптичне розпізнавання (перетворення формату JPG–DOC).

  7. Скорегувати перетворений текст кожної сторінки (команда Проверка).

  8. Зберегти сторінки та створити єдиний документ у форматі DOC.

  9. Останню сторінку із додатку Fine Reader зберегти у форматах DOC, RTF, PDF, HTM, Unicode HTML(UTF-8), TXT.

  10. Визначити розмір файлів сторінки в зазначених шести форматах, занести значення в таблицю Word або Excel, побудувати порівняльну діаграму.

  11. У звіті лабораторної роботи навести назву та мету роботи, останню сторінку відсканованого тексту у форматі JPG (як додаток до звіту), єдиний документ у форматі DOC, таблицю розмірів останньої розпізнаної сторінки у відповідності п. 9 та порівняльну діаграму. Наприкінці звіту зробити висновки.

  12. По закінченні роботи зробити деінсталяцію пакета за допомогою додатка Uninstall або вручну. При видаленні вручну спочатку видалити з робочого стола й з меню Пуск ярлики за допомогою послідовності команд Пуск > Настройка >Панель задач и меню Пуск > Настройка меню > Удалить > ярлык Fine32 > Удалить > ОК, а потім видалити з диска D папки Fine і ABBYY FineReader.
Варіанти завдань

вар.

1

2

3

4

5

6

7

8

9

10

стор.

1-5

6-10

11-15

16-20

21-25

26-30

31-35

36-40

3-7

8-12

вар.

11

12

13

14

15

16

17

18

19

20

стор.

13-17

18-22

23-27

28-32

33-37

38-42

43-47

9-13

14-18

19-23

вар.

21

22

23

24

25

26

27

28

29

30

стор.

24-28

29-33

34-38

39-43

44-48

3-7

8-12

13-17

18-22

23-27


Лабораторна робота N2

^

Вивчення пакетів мовного розпізнавання тексту DragonNaturallySpeakingPersonalEdition 1.0 і Диктант 2.5



Мета – вивчення інтерфейсу користувача й основних навичок роботи c пакетами мовного розпізнавання тексту DragonNaturallySpeakingPersonalEdition 1.0 і Диктант 2.5.

^

Методичні вказівки до виконання


  1. Скопіювати із папки мережеве оточення – Server на диск D: робочої станції папки Dragonsp.10 і Dictate.25.

  2. Зробити інсталяцію пакетів у папки D:\Dragon і D:\Dictate.

  3. Помістити ярлики додатків Natspeak і Voicebar на робочий стіл, а при необхідності й у меню Пуск за допомогою послідовності команд Пуск > Настройка > Панель задач и меню «Пуск» > Меню Пуск > Настроить > Добавить > Обзор > D:\Dragon\Natspeak.exe > Рабочий стол або Программы > Готово > ОК.

  4. Запустити додатки, ознайомитися з їхнім інтерфейсом користувача.

  5. Зробити тести аудіосистеми робочої станції, необхідні для початку роботи з пакетами.

  6. Для пакета Dragon здійснити мовне уведення обраного фрагмента тексту англійською мовою. При необхідності скорегувати уведений текст і зробити додаткове навчання розпізнавача за допомогою команд Tools > Train words або Tools > VOCabulary Builder.

  7. Для пакета Диктант за допомогою команд Голосовое меню > Возможности > Добавить слово зробити додаткове навчання для уведення обраного фрагмента тексту російською мовою за допомогою додатка Блокнот і голосове керування додатком Калькулятор. Запустити додаток Блокнот, Калькулятор і провести роботу з ними під керуванням мовного розпізнавача Диктант.

  8. По закінченні роботи зробити деінсталяцію пакета за допомогою додатка Uninstall або вручну. При видаленні вручну спочатку видалити з робочого стола й з меню Пуск ярлики Пуск > Настройка > Панель задач і меню Пуск > Настройка меню > Удалить > Natspeak >Удалить > ОК, а потім видалити з диска D: папки Dragonsp.10 і Dictate.25.
^

Лабораторна робота N3




Вивчення основних мультимедійних можливостей RAD середовища Delphi



Мета – вивчення основних компонентів RAD середовища Delphi для роботи із графічними, звуковими або відео даними, їхніх властивостей і методів

^

Методичні вказівки до виконання





  1. Відповідно до обраного варіанта (варіант відповідає порядковому номеру студента по журналі) розробити додаток у середовищі Delphi.

  2. Звіт повинен мати

  • назву та мету роботи;

  • копії екранів із головною формою додатка, вікон роботи додатку;

  • тексти основних оброблювачів мовою Object Pascal;

  • висновки по роботі.

Варіанти завдань: Розробити додаток для обробки і представлення даних:

1. Плавної зміни тону кольору форми по HSB моделі. Перехід від одного кольору до іншого повинен здійснюватися через заданий проміжок часу, обумовленого компонентом Timer.

2. Побудови на компоненті PaintBox графіка функції y=sin(x)/x (0. Додаток повинен включати компонент FontDialog для вибору кольорів, стилів і розмірів написів. Графік повинен виводитися в анімаційному режимі, обумовленому компонентом Timer.

3. Повної колірної інверсії і інверсії колірних складових зображення у форматі BMP. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення й компоненти Radio Button і RadioGroup для вибору режиму інверсії.

4. Виділення колірних складових зображення у форматі BMP. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення й компоненти Radio Button і RadioGroup для вибору виділюваної складової.

5. Пригнічення колірних складових зображення у форматі BMP. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення й компоненти Radio Button і RadioGroup для вибору складової, що пригнічується .

6. Формування зображення, дзеркального до заданого зображення. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення.

7. Формування зображення із прозорим (невидимим) кольором. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення. Піксел зі зразком прозорого кольору повинен задаватися за допомогою миші.

8. Малювання за допомогою миші на компоненті PaintBox графічних примітивів: відрізка, прямокутника, еліпса, окружності. Додаток повинен містити компоненти Radio Button і RadioGroup для вибору типу примітива, що малюється.

9. Малювання за допомогою миші на формі відрізків. Додаток повинен забезпечувати вивід на форму розмічальної сітки із заданими кроками по осях і при необхідності забезпечувати прив'язку примітивів до розмічальної сітки. Для уведення значень кроків використати компоненти Edit, а для включення/вимикання режиму прив'язки компонент CheckBox.

10. Побудови на формі графіка функції y=(1-x2)(x-2) (-2 Додаток повинен включати компоненти Radio Button і RadioGroup для вибору кольорів, стилів і розмірів написів та побудови осів координат. Графік повинен виводитися в анімаційному режимі, забезпечуваному компонентом Timer.

11. Побудови на формі анімаційної картинки обертання одного компонента Shape (еліпс) навколо іншого (коло). У процесі обертання повинні випадковим образом змінюватися властивості компонентів малювання Color i Width.

12. Побудови на формі компонента Shape з можливістю його масштабування й зміни властивостей Shape, Pen.Color, Pen.Style, Brush.Color, Brush.Style. Для установки коефіцієнта масштабування використати компонент Edit, для установки властивостей – компоненти СomboBox.

13. Заповнення компонента РaintBox примітивами випадкового розміру й кольору. Для вибору виду примітива (крапка, коло, квадрат) використати компонент ComboBox, а для установки розміру примітива Edit.

14. Виводу довільного фрагмента AVI кліпу за допомогою компонента Animate. Для визначення імені файлу, що відкривається, використати компонент OpenDialog, a установки номерів початкових, кінцевого кадрів і кількості повторень – компоненти Edit.

15. Побудови на формі графіка функції y=(x-1)sin(x) (-2. Додаток повинен містити компоненти компоненти Radio Button і RadioGroup для вибору кольорів осей і графіка. Графік повинен виводитися в анімаційному режимі, забезпечуваному компонентом Timer.

16. Відтворення AVI, CDA, MID, WAV файлів (а для останнього типу й запису) за допомогою компонента MediaPlayer. Для визначення імені файлу, що відкривається, використати компонент ОpenDialog, а для визначення типу медіа - пристрою – СomboBox.

17. Формування зображення, зменшеного в розмірах стосовно заданого зображення у форматі BMP. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення й компоненти Edit для уведення коефіцієнтів масштабування.

18. Формування зображення, збільшеного в розмірах стосовно заданого зображення у форматі BMP. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення й компоненти Edit для уведення коефіцієнтів масштабування.

19. Циклічного почергового виводу на компонент Image через заданий проміжок часу, який обумовлюється компонентом Timer, послідовності метафайлів, визначених в компоненті Memo.

20. Побудови на формі графіка функції y=sin(exp(x)) (-2. Додаток повинен включати компонент ColorDialog для вибору кольорів осей і графіка. Графік повинен виводитися в анімаційному режимі, забезпечуваному компонентом Timer.

21. Формування зображення, яскравість якого зменшена стосовно заданого зображення у форматі BMP. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення й компонент Edit для уведення коефіцієнта масштабування.

22. Побудови на формі анімаційної картинки обертання одного компонента Shape навколо іншого. У процесі обертання повинні випадковим образом змінюватися властивості ShapeType i Color компонентів.

23. Формування зображення, інтенсивності колірних компонентів якого зменшені стосовно заданого зображення у форматі BMP. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення й компонент Edit для вибору коефіцієнтів масштабування.

24. Реалізацію інструмента пензель. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення.

25. Реалізацію інструмента піпетка. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення, компонент Image для відображення зразка кольору і компоненти Label для виводу значень інтенсивностей RGB компонент кольору.

26. Реалізацію інструмента об’ємна піпетка. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення, компонент Image для відображення зразка кольору, який є усередненим для заданої прямокутної області, що задається мишею, і компоненти Label для виводу значень інтенсивностей RGB компонент кольору.

27. Перетворення кольорового зображення у монохромне. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення.

28. Перетворення кольорового зображення у зображення, яке представлено у шкалі сірого. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення.

29. Вирізки з наданого зображення прямокутного блока пікселів і подання його в укрупненому масштабі. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення.

30. Повороту зображення квадратної форми на кут, кратний 45о. Додаток повинен включати компоненти OpenPictureDialog, SavePictureDialog для завантаження й збереження зображення.
^

Лабораторна робота N4 – не делаем




Вивчення основних графічних форматів



Мета – ознайомлення з основними форматами подання графічних даних і графічним редактором Corel Draw! як засобом їхньої конвертації

^

Методичні вказівки до виконання


  1. Стартувати пакет Corel Draw! . Використовуючи команди Файл > Импорт, імпортувати в середовище пакета растровий графічний малюнок з колірним розділенням 24 або 32 bрр.

  2. Використовуючи команди ^ Файл > Экспорт, експортувати малюнок у растрових форматах BMP, JPG, PCX, TIF і у форматі метафайла WMF. При експорті стежити за збереженням геометричних розмірів, оптичного й колірного розділення зображення. Зафіксувати обсяги пам'яті, займані файлами різних форматів і пронормувати їх на максимальний розмір.

  3. Перетворити вихідний малюнок у колірне розділення 1 і 8 bрр.

  4. Повторити дії п.2, додавши до експортних растрових форматів формат GIF.

Результати представити у вигляді табл. 1

Таблиця 1



Формат


BMP


GIF


JPG


PCX


TIF


WMF

Глубина

цвета, bpp

1



















8



















24






















  1. Створити у графічному редакторі Paint малюнок, що складається з декількох графічних примітивів і зберегти його у форматі BMP. Імпортувати зазначений малюнок у середовище Corel Draw!, а потім зберегти у векторному форматі CDR і експортувати у форматі DXF. Порівняти обсяги пам'яті, займані отриманими файлами. Використовуючи текстовий редактор NotePad, ознайомитися із внутрішньою структурою файлу у форматі DXF.

  2. Вивчити можливість імпорту – експорту графічних даних в отриманих форматах додатками Paint, Imaging, Microsoft PhotoEditor, Microsoft Word.
^

Варіанти завдань: набори файлів з малюнками для конвертації форматів за вказівкою викладача.

Лабораторна робота N5




Вивчення основних форматів звукових даних і способів стиску цифрового звуку



Мета – ознайомлення з основними форматами подання звукових даних, засобами їхньої конвертації, а також способами стиску цифрового звуку

^

Методичні вказівки до виконання


  1. Використовуючи команди Windows Пуск > Программы > Стандартные > Звукозапись, стартувати додаток Звукозапись. Вивчити основне меню додатка.

  2. Записати звукові дані у вигляді розмови (наприклад контрольний рахунок, читання віршу або байки) і зберегти їх у файловому форматі WAV, використовуючи для кодеки: PCM, IMA ADPCM, CCITT, DSP Group True Speech, GSM. Запис робити з мінімально можливою частотою дискретизації й розрядністю оцифровки, припустимої для даного кодека у варіанті моно. Для кодека РСМ також зробити запис у варіанті стерео для двох різних частот дискретизації й розрядностей оцифровки. Зафіксувати обсяги пам'яті, займані файлами, з різними варіантами кодеками й пронормувати їх на максимальний розмір. Прослухати отримані файли й зафіксувати можливе падіння якості при деяких способах кодування.

  3. Повторити дії п. 2, використовуючи в якості вихідних звукові дані у вигляді музики, записаної у форматі WAV.

  4. Вивчити основні можливості програми Звукозапись по редагуванню звукових даних і додаванню у звукозапис спецефектів. Використовуючи файли, отримані в п.2,3 створити звукові файли зі зміненою швидкістю, гучністю, додаванням луни, що містять накладені й послідовно звучну музику й мову.

  5. Установити на диску D: робочої станції плеєр JetAudio і конвертори звукових форматів MPEG Encoder, MIDtoWAV ефектів.

  6. Використовуючи програму MPEG Encoder, перетворити один з отриманих файлів з формату WAV у формат MP3. Зафіксувати обсяг отриманого файлу. Відтворити його за допомогою плеєра JetAudio.

  7. Використовуючи в якості вихідних звукові дані у вигляді музики, записаної у форматі MIDI і програму MIDtoWAV, перетворити їх у формат WAV. Зафіксувати обсяг отриманого файлу. Відтворити його за допомогою плеєра JetAudio.



^

Лабораторна робота №6 - не делаем




Вивчення основних принципів файлової організації даних цифрового звуку



Мета – одержання практичних навичок по перетворенню аудіоформатов, дослідженню їхньої внутрішньої структури з використанням переглядачів (редакторів) шеснадцатиричних (НЕХ) кодів і програмуванню додатків для розбору їхньої внутрішньої структури.

^

Методичні вказівки до виконання


  1. З використанням аксесуара ОС Windows Sound Recorder відкрити з папки Windows\Media звуковий файл формату WAV, що містить стереозвук у поданні РСМ із частотою дискретизації fd=22,05 кГц і розрядністю оцифровки C=16 біт.

Варіюючи один з параметрів вихідного файлу, зробити збереження даних зі зміненими параметрами:

  • частотою дискретизації 11,025 і 44,1 кГц;

  • розрядністю оцифровки 8 біт;

  • у монофонічному виді.

Зробити збереження вихідних даних з використанням аудіокодеків CCITT a-Law/u-Law(-Law), Microsoft ADPCM, DSP Group True Speech, GSM 6.10, MPEG Layer - 3. У випадку, якщо аудіокодек не підтримує один або кілька параметрів вихідних даних, вибрати найближчі за значенням.

Результати представити у вигляді табл. 2

Таблиця 2


Аудіокодек

Частота дискре-тизації, Кгц

Розряд-ність кванту-вання, біт


Число каналів


Розмір файлу, Кб


Питомий информаційній потік, Кб/с


Коэф-фіцієнт

стиску

Перевірити виконання співвідношення для обсягу пам'яті ^ V, займаного цифровим звуком без урахування стиску, що можливо забезпечує аудіокодек


V=k C fdt


де k – число каналів (1 – моно, 2 – стерео), t – час звучання.

  1. З використанням наявного звукового редактора зробити збереження вихідних даних у форматі VOC. Відкрити файл у переглядачі (редакторі) HEX кодів і знайти байти, що несуть наступну інформацію:

  • код версії файлового формату;

  • контрольне значення коду версії;

  • код аудіокодека;

  • код числа каналів;

  • код наближеного значення частоти дискретизації;

  • код точного значення частоти дискретизації;

  • довжина звукових даних.

Одержати відповідні десяткові коди й значення даних.

Результати представити у вигляді табл. 3

Таблиця 3

Номера байтів

Опис даних

НЕХ код

Десятковий код

Значення

даних




  1. З використанням інструментального середовища програмування розробити додаток, що реалізує функцію розбирача файлового формату цифрового звуку VOC, наведену в табл. 4.

Таблиця 4

Номер

варіанта

Реалізована функція

1, 17

Перевірка відповідності файлу формату VOC і його специфікованим версіям

2, 18

Визначення числа блоків продовження звукових даних


3, 19

Визначення основних параметрів файлу, що містить монофонічний звук: версії файлового формату, типу аудіокодека, числа каналів, частоти дискретизації, довжини звукових даних першого блоку.


4, 20

Визначення основних параметрів файлу, що містить звук з довільною кількістю каналів: версії файлового формату, типу аудіокодека, числа каналів, частоти дискретизації, довжини звукових даних першого блоку.


5, 21

Визначення довжини звукових даних першого блоку файлу, що містить монофонічний звук і вставки в його довільну позицію блоку паузи


6, 22

Визначення довжини звукових даних першого блоку файлу, що містить монофонічний звук і вставки в його довільну позицію текстового блоку


7,23

Визначення довжини звукових даних першого блоку файлу, що містить монофонічний звук і вставки в його довільні позиції блоків повторення


8, 24

Визначення довжини звукових даних першого блоку файлу, що містить стереофонічний звук і вставки в його довільну позицію блоку паузи


9, 25

Визначення довжини звукових даних першого блоку файлу, що містить стереофонічний звук і вставки в його довільну позицію текстового блоку


Продовження таблиці 4


Номер

варіанта

Реалізована функція


10, 26

Визначення довжини звукових даних першого блоку файлу, що містить стереофонічний звук і вставки в його довільні позиції блоків повторення

11, 27

Побудова осцилограми звукового сигналу файлу, що містить монофонічний звук у єдиному блоці


12, 28

Побудова осцилограми звукового сигналу файлу, що містить монофонічний звук у довільній кількості блоків


13, 29

Перетворення файлу стереофонічного звуку з єдиним блоком звукових даних у файл монофонічного звуку з можливістю вибору каналу


14, 30

Перетворення файлу стереофонічного звуку з довільною кількістю блоків продовження звукових даних у файл монофонічного звуку з можливістю вибору каналу

15

Побудова осцилограми звукового сигналу файлу, що містить стереофонічний звук у єдиному блоці


16

Побудова осцилограми звукового сигналу файлу, що містить стереофонічний звук у довільній кількості блоків



^

Лабораторна робота N7




Вивчення пакетів обробки аудіоданных


Мета – вивчення інтерфейсу користувача й основних навичок роботи cо звуковим редактором CoolEditPro 1.0 і секвенсором SoundClub 2.0

^

Методичні вказівки до виконання


  1. Зробити інсталяцію пакетів CoolEditPro 1.0 і SoundClub 2.0 на диск D: робочої станції.

  2. Запустити додатки, ознайомитися з їхнім інтерфейсом користувача.

  3. Для секвенсора SoundClub створити партитуру, що включає по одному голосу духового, ударного й струнного інструментів. Прослухати партитуру й зберегти її у форматах SN2, MOD, WAV. Порівняти обсяги отриманих звукових файлів.

  4. Для звукового редактора CoolEditPro зробити наступні дії, зберігаючи отримані фонограми в окремих файлах у форматі WAV:

  • записати звукові дані у вигляді мови (наприклад контрольний рахунок). Застосувати до них найпростіші прийоми редагування фонограми (видалення частини фонограми, копіювання в буфер, вставка з буфера в інше місце, лінійне посилення) і звукові ефекти (обертання фонограми в часі, додавання луни);

  • використовуючи в якості вихідних звукові дані у вигляді музики, записаної у форматі WAV, зробити додавання до них і мікшування з ними мовних даних;

  • згенерувати сигнал, що включає основну гармоніку із частотою 1000 Гц, а також рівні по амплітуді другу й третю гармоніки. Переглянути тонку часову структуру отриманого сигналу й зробити його спектральний аналіз;

  • згенерувати білий, рожевий, коричневий шуми й зробити їхній спектральний аналіз;

  • змікшувати генерований сигнал з рівним по тривалості білим шумом, переглянути тонку часову структуру й зробити спектральний аналіз отриманої фонограми;

  • зробити очищення сигналу від шуму з використанням фільтра на основі швидкого перетворення Фур'є, графічного й параметричного еквалайзерів. Зробити висновок про ефективність пригнічення шуму різними способами.



^

Лабораторна робота N8




Вивчення програм для роботи з відеоданими


Мета – вивчення інтерфейсу користувача й основних навичок роботи з відеоредактором MPEGVCR 3.00 і засобів перетворення файлових форматів відеоданих

^

Методичні вказівки до виконання


  1. Переписати з папок MPG1VCR 3.0, Encoders, Data_files сервера на диск D: робочої станції інсталятор відеоредактора MPEGVCR 3.00, конвертори AVI2MPEG1 1.4, MPEG2AVI 0.14, кілька відеофайлів у форматах AVI, MPEG, і аудіофайл у форматі МР3.

  2. З використанням конверторів зробити конверсію одного файлу у форматі AVI у формат MPEG і файлу у форматі MPEG у формат AVI. В останньому випадку провести стиск відеокомпоненти з використанням всіх кодеков, що підтримуються конвертором. Дослідити залежність обсягу одержуваного файлу від формату й кодека.

  3. Зробити інсталяцію пакета MPEGVCR 3.00 на диск D: робочої станції. Ознайомитися з його інтерфейсом користувача.

  4. З використанням відеоредактора

  • зробити декомпозицію відео й звукового компонента MPEG файлу зі звуковим супроводом.

  • створити композицію MPEG файлу без звукового супроводу й аудіофайла формату МР3.

  • зробити редагування одного відеокліпу шляхом видалення з нього фрагмента й вставки його в іншу частину кліпу.

  • виконати вставку у відеокліп іншого відеокліпу з використанням і без використання ефекту накладення. Отримані кліпи зберегти в окремі файли у форматі MPEG.

  • з використанням убудованого конвертора здійснити перетворення зазначених файлів у формат DAT.
^

Лабораторна робота №9




Створення мультимедійних презентацій за допомогою додатку MS Power Point



Мета – за допомогою офісного додатка Microsoft Power Point створити мультимедійну презентацію аналітично заданої поверхні згідно обраного варіанта (номер по журналу). Презентація повинна включати

  • титульний слайд ;

  • текстовий та математичний опис поверхні зроблені з анімаційними ефектами;

  • графічні статичні та анімаційні зображення поверхні, що створені за допомогою математичного пакету MathCad;

  • слайд із відомостями про розроблювача презентації;

  • підсумковий слайд;

  • єдиний шаблон оформлення всіх слайдів презентації;

  • довільно вибрані відеоефекти переходу між слайдами;

  • анімацію об’єктів кожного слайда;

  • кнопки керування режимом перегляду слайдів;

  • звукове супроводження презентації. В варіантах з непарними номерами звукове супроводження робиться до презентації в цілому, а з парними номерами до кожного слайду окремо. Всі об’єкти додаються до презентації за допомогою проникнення або зв’язування;

Підготовити два варіанта показу презентации – автоматичний показ зі зміною слайдів за часом і керований користувачем показ.

Звіт повинен містити опис структури презентації в цілому та кожного слайду окремо, а також роздруківку або ескізи зображень слайдів. До звіту також додаються файли презентації та даних, що зв’язані з презентацією.

Варіанти завдань (рівняння поверхні):

1. a=1 b=2


2. R=12


3.


4.


5.


6.


7.


8.


9.


10.


11.

12.

13.


14.


15.


16.


17.


18.


19.


20.


21. a=1 b=1


22. R=12


23. R=15


24.


25.


26.


27.


28.


29.


30.

Лабораторна робота N10

^

Cтворення фільмів за допомогою авторської системи мультимедіа Macromedia Flash




Мета – вивчити основні можливості авторської системи на основі часової шкали Macromedia Flash для створення анімації Web- сторінок Інтернету.



За допомогою авторської системи мультимедіа Macromedia Flash створити базовий HTML – документ та його мультимедійні аплети у вигляді відеокліпів в форматах AVI, SWF та анімованого GIF, що задовольняють вимогам табл. 5

Таблиця 5


Номер

варіанта

Об’єкт анімації

Вид анімації*)

Додаткові вимоги

1, 13, 25

фігура

морфування

ідентифікатори форм

2, 14, 26

екземпляр символу типа Graphics

зміна колірних властивостей

звукове супроводження

3, 15, 27

екземпляр символу типа Button

прямолінійного руху з обертанням

маска


4, 16, 28

екземпляр символу типа MovieClip

руху уздовж довільно заданої траєкторії

растрова підкладка на окремому шарі

5, 17, 29

текст

прямолінійного руху з обертанням

маска


6, 18, 30

імпортоване растрове зображення

руху уздовж довільно заданої траєкторії

звукове супроводження

7, 19

фігура

зміна колірних властивостей

растрова підкладка на окремому шарі

8, 20

екземпляр символу типа Graphics

морфування

ідентифікатори форм

9, 21

екземпляр символу типа Button

руху уздовж довільно заданої траєкторії

растрова підкладка на окремому шарі

10, 22

екземпляр символу типа MovieClip

зміна колірних властивостей

звукове супроводження

11, 23

текст

морфування

ідентифікатори форм


12, 24

імпортоване растрове зображення

прямолінійного руху з обертанням


маска


*) – якщо вказаний об’єкт не піддається заданому виду анімації, його треба попередньо перетворити у об’єкт необхідного типу. Для екземплярів символів типа MovieClip заданий вид анімації повинен бути визначений всередині символу. Для варіантів 1 – 15 створити кадровану анімацію, а для варіантів 16 – 30 – покрокову.


Рекомендована література


1. Кречман Д.Л., Пушков А.И. Мультимедиа своими руками. СПб. БХВ Санкт-Петербург, 1999. – 528 с., ил.

2. Кинтцель Т. Руководство программиста по работе со звуком. М.: ДМК Пресс, 2000 – 432 с., ил.

3. Фаронов В.В. Delphi 5. Учебный курс. — М.: «Нолидж», 2000. 608 с., ил.

4. Панкратова Т. Flash 5. Учебный курс. — СПб.: Питер, 2002. —368 с., ил.


Зміст


Лабораторна робота N1. Вивчення пакета оптичного розпізнавання тексту FineReader................................................................................................. 4

Лабораторна робота N2. Вивчення пакетів мовного розпізнавання тексту DragonNaturallySpeakingPersonalEdition 1.0 і Диктант 2.5............................ 5

Лабораторна робота N3. Вивчення основних мультимедійних можливостей RAD середовища Delphi............................................................... 6

Лабораторна робота N4. Вивчення основних графічних форматів.............. 9

Лабораторна робота N5. Вивчення основних форматів звукових даних і способів стиску цифрового звуку........................................................................ 10

Лабораторна робота №6. Вивчення основних принципів файлової організації даних цифрового звуку.......................................................................................... 11

Лабораторна робота N7. Вивчення пакетів обробки аудіоданных............. 14

Лабораторна робота N8. Вивчення програм для роботи з відеоданими.... 15

Лабораторна робота №9. Створення мультимедійних презентацій за допомогою додатку MS Power Point .................................................................. 16

Лабораторна робота N10. Cтворення фільмів за допомогою авторської системи мультимедіа Macromedia Flash ......................................................... 19

Укладачі:

Валерій Олександрович Трусов

Антон Вячеславович Кожевников


Методичні вказівки та індивідуальні завдання

до лабораторних робіт з дисципліні

“Засоби мультимедіа в нових інформаційних технологіях”

для студентів спеціальностей 7.080401 і 7.080403


Редакційно-видавничій комплекс

Редактор

Підписано до друку . Формат

Папір Pollux. Різографія. Умовн. Друк. арк .

Обліково-відавн. арк. . Тираж 50 прим. Зам. № .


НГУ

49027. м. Дніпропетровськ – 27, просп. К.Маркса, 19.




Схожі:

Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconСтворення нової папки Відкрити папку де потрібно створити нову папку Дати команду «Створити папку»

Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconD: Програму на диск D: можна встановити таким способом: скопіювати папку курс\ з диска С
Комплекс «Курс» знаходиться у стадії розробки, тому необхідно постійно оновлювати версію, для цього слід регулярно виходити на сайт...
Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconЗавдання для 5 класу для самоопрацювання на період припинення занять Німецька мова Зайчикова Л. С. Повторити слова з теми „Моя сім’я та мої друзі”
Розглянемо один із них. Для того щоб скопіювати файл чи папку, потрібно виділити об`єкт і в меню Правка виконати команду Копіювати...
Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconГавалюк Тарас Іванович
Системне та мережеве адміністрування серверних ос microsoft Windows Server 2003, 2008
Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconМетодичні вказівки до виконання контрольних робіт для студентів спеціальності ксм
Методичні вказівки містять завдання до виконання контрольної роботи з курсу «Операційні системи». Матеріал подано у вигляді окремих...
Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconМетодичні вказівки для виконання практичних завдань
Методичні вказівки рекомендовано до друку методичною комісією економічного факультету, протокол №7 від 12. 03. 2009
Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconМетодичні вказівки до виконання лабораторних робіт із курсу „основи океанології дніпропетровськ рвв дну
Уміщені методичні вказівки до виконання лабораторних робіт із дисципліни „Основи океанології”. Наведені рекомендації до виконання...
Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconМетодичні вказівки до виконання індивідуального завдання для студентів
Програма та методичні вказівки до виконання індивідуально завдання для студентів денної форми навчання галузі знань 0505 «Машинобудування...
Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconМетодичні вказівки до виконання курсового проекту рекс -ікт спеціальність 01010436 Харків 2007
Методичні вказівки до виконання курсового проекту з дисципліни «Автоматизовані системи організаційного управління» для спеціальності...
Методичні вказівки до виконання Скопіювати із папки мережеве оточення Server на диск D: робочої станції папку FineReader iconПрактичне заняття №11 виконання перекладу документів у середовищі електронних таблиць ms excel
На Робочем столе створіть папку для запису в ній створеної робочої книги Самостійні завдання
Додайте кнопку на своєму сайті:
Документи


База даних захищена авторським правом ©te.zavantag.com 2000-2017
При копіюванні матеріалу обов'язкове зазначення активного посилання відкритою для індексації.
звернутися до адміністрації
Документи